DiRT Rally

  • DiRT Rally Screenshot 1
  • DiRT Rally Screenshot 2
  • DiRT Rally Screenshot 3
  • DiRT Rally Screenshot 4
  • DiRT Rally Screenshot 5
  • DiRT Rally Screenshot 6
  • DiRT Rally Screenshot 7
  • DiRT Rally Screenshot 8
  • DiRT Rally Screenshot 9
  • DiRT Rally Screenshot 10
  • DiRT Rally Screenshot 11
  • DiRT Rally Screenshot 12

Region restrictions

Activates within United States
This game has world-wide activation. No known region restrictions in effect.

Description

Requirements

Mac Reqs Minimum Supported Will It Run?
Mac OS X10.13Download the MacGameStore App to compare your Mac's information in real-time.

Get the Mac App
64bit SupportYes
CPU TypeIntel Mac Only
CPU CoresAny
CPU Speed1.8 GHz
System RAM8 GB
Drive Space48 GB
Video RAM1 GB
Video (ati)AMD FirePro D300 *
* Unsupported Video Cards: ATI Radeon X1300, ATI Radeon X1600, ATI Radeon X1900 XT, ATI Radeon HD 2400 XT, ATI Radeon HD 2600 Pro, ATI Radeon HD 2600 XT, ATI Radeon HD 4670, ATI Radeon HD 4850, ATI Radeon HD 4870, ATI Radeon HD 5670, ATI Radeon HD 5750, ATI Radeon HD 5770, ATI Radeon HD 5870, AMD Radeon HD 6490M, AMD Radeon HD 6630M, AMD Radeon HD 6750M, AMD Radeon HD 6770M, AMD Radeon HD 6970M
Video (nvidia)NVIDIA GeForce GT 650M *
* Unsupported Video Cards: NVIDIA Quadro FX 4500, NVIDIA Quadro FX 5600, NVIDIA GeForce Go 7300, NVIDIA GeForce 7300 GT, NVIDIA GeForce 8600M GT, NVIDIA GeForce 8800 GS, NVIDIA GeForce 8800 GT, NVIDIA GeForce 9400M, NVIDIA GeForce 9400, NVIDIA GeForce 9600M GT, NVIDIA GeForce GT 120, NVIDIA GeForce GT 130, NVIDIA GeForce 320M, NVIDIA GeForce GT 330M, NVIDIA GeForce GT 540M, NVIDIA GeForce GT 640M
Video (intel)Intel HD Graphics 4000 *
* Unsupported Video Cards: Intel GMA 900, Intel GMA 950, Intel GMA X3100, Intel HD Graphics, Intel HD Graphics 3000
Important Notes:
  • Requires Steam and a Steam Account to play.
  • The game is supported on the following Macs. To check your Mac model and when it was released, select About This Mac from the Apple Menu on your desktop:
  • • All MacBook Airs released since mid 2012 with a 1.6GHz i5 Processor or better
  • • All 13” MacBook Pros released since Mid 2012
  • • All 15” MacBook Pros released since Mid 2012 with a 1GB graphics card or better
  • • All Mac Minis released since Late 2012
  • • All 21.5” iMacs released since Late 2013
  • • All 27” iMacs released since Late 2012 with a 1GB graphics card or better
  • • All Mac Pros released since Mid 2010 with an AMD 7950 (Mac Edition)
Other Requirements:
The following Macs are capable of running the game but do not consistently meet the standards required for official support: • All MacBook Airs released since mid 2012 without a 1.6GHz i5 Processor or better • All MacBooks released since early 2016

Reviews & Comments

0
From 0 Shoppers
5
 
0
4
 
0
3
 
0
2
 
0
1
 
0
No reviews to list at this time.

More By Feral Interactive