About macOS 10.15 Catalina & your older games...

Total War: WARHAMMER

  • Total War: WARHAMMER Screenshot 1
  • Total War: WARHAMMER Screenshot 2
  • Total War: WARHAMMER Screenshot 3
  • Total War: WARHAMMER Screenshot 4
  • Total War: WARHAMMER Screenshot 5
  • Total War: WARHAMMER Screenshot 6
  • Total War: WARHAMMER Screenshot 7
  • Total War: WARHAMMER Screenshot 8
  • Total War: WARHAMMER Screenshot 9

Region restrictions

Activates within United States
This game has world-wide activation. No known region restrictions in effect.

Description

Requirements

Mac Reqs Minimum Supported Will It Run?
Mac OS X10.12.4Download the MacGameStore App to compare your Mac's information in real-time.

Get the Mac App
64bit SupportYes
CPU TypeIntel Mac Only
CPU Cores2
CPU Speed2 GHz
System RAM8 GB
Drive Space37 GB
Video RAM1.5 GB
Video (ati)AMD FirePro D300 *
* Unsupported Video Cards: ATI Radeon X1300, ATI Radeon X1600, ATI Radeon X1900 XT, ATI Radeon HD 2400 XT, ATI Radeon HD 2600 Pro, ATI Radeon HD 2600 XT, ATI Radeon HD 4670, ATI Radeon HD 4850, ATI Radeon HD 4870, ATI Radeon HD 5670, ATI Radeon HD 5750, ATI Radeon HD 5770, ATI Radeon HD 5870, AMD Radeon HD 6490M, AMD Radeon HD 6630M, AMD Radeon HD 6750M, AMD Radeon HD 6770M, AMD Radeon HD 6970M
Video (nvidia)NVIDIA GeForce GT 650M *
* Unsupported Video Cards: NVIDIA Quadro FX 4500, NVIDIA Quadro FX 5600, NVIDIA GeForce Go 7300, NVIDIA GeForce 7300 GT, NVIDIA GeForce 8600M GT, NVIDIA GeForce 8800 GS, NVIDIA GeForce 8800 GT, NVIDIA GeForce 9400M, NVIDIA GeForce 9400, NVIDIA GeForce 9600M GT, NVIDIA GeForce GT 120, NVIDIA GeForce GT 130, NVIDIA GeForce 320M, NVIDIA GeForce GT 330M, NVIDIA GeForce GT 540M, NVIDIA GeForce GT 640M, NVIDIA GeForce GT 650M, NVIDIA GeForce GTX 660M, NVIDIA GeForce GTX 675MX
Video (intel)Not Supported
Important Notes:
  • Requires Steam and a Steam Account to play.
  • The game is supported on the following graphics cards:
  • All AMD graphics cards released from 2014 onwards
  • All Nvidia cards with 2GB+ VRAM released from 2012 onwards
  • (MacBookPro only) Intel Iris Graphics 540 & 550 cards released from 2016 onwards
  • The following graphics cards are capable of running the game, but do not consistently meet the standards required for official support:
  • All Nvidia cards with 1 GB VRAM released from 2012 onwards
  • All Intel Iris and Iris Pro cards released from 2013 onwards apart from the 540 and 550 cards listed above.
Other Requirements:
This game is not currently supported on volumes formatted as Case-sensitive.

Reviews & Comments

4
From 2 Shoppers
5
 
1
4
 
0
3
 
1
2
 
0
1
 
0
  1. Finally

    I have been waitinf for a Total War game set in a fantasty universe and this finally scratched my itch. It's more classic total war gameplay so if that's not your thing, this isn't going to change your mind. I just with they could get the license to do a Lord fo the Rings one...

    by Louis DeLaura, USA - Nov 22nd 2018
    Was this helpful? Yes No
  2. Poor performance, but 10/10 game

    The campaign map runs at 2FPS, if that. It makes it almost unplayable, but the battles run just fine. Incredible game, but make sure your computer can run it

    by Grant Higgins, USA - Oct 2nd 2018
    Was this helpful? Yes No

More By Feral Interactive