About macOS 10.15 Catalina & your older games...

Collapse!

  • Collapse! Screenshot 1
  • Collapse! Screenshot 2
  • Collapse! Screenshot 3
  • Collapse! Screenshot 4

Download the free trial

Description

Requirements

Mac Reqs Minimum Supported Will It Run?
Mac OS X10.5.8 *Download the MacGameStore App to compare your Mac's information in real-time.

Get the Mac App
* Not compatible with: 10.7+, 10.8+, 10.9+, 10.10+, 10.11+, 10.12+, 10.13+, 10.14+, 10.15+
64bit SupportNo
CPU TypeUniversal
CPU CoresAny
CPU SpeedAny
System RAMAny
Drive SpaceUnknown
Video RAMAny
Video CardAny
Important Notes:
  • Not compatible with OS X 10.7 Lion and later OSX/macOS.

Reviews & Comments

3.6
From 7 Shoppers
5
 
2
4
 
0
3
 
5
2
 
0
1
 
0
No reviews to list at this time.

More By GameHouse