Trine: Ultimate Collection

  • Trine: Ultimate Collection Screenshot 1
  • Trine: Ultimate Collection Screenshot 2
  • Trine: Ultimate Collection Screenshot 3
  • Trine: Ultimate Collection Screenshot 4
  • Trine: Ultimate Collection Screenshot 5
  • Trine: Ultimate Collection Screenshot 6
  • Trine: Ultimate Collection Screenshot 7
  • Trine: Ultimate Collection Screenshot 8
  • Trine: Ultimate Collection Screenshot 9
  • Trine: Ultimate Collection Screenshot 10
  • Trine: Ultimate Collection Screenshot 11
  • Trine: Ultimate Collection Screenshot 12
  • Trine: Ultimate Collection Screenshot 13
  • Trine: Ultimate Collection Screenshot 14
  • Trine: Ultimate Collection Screenshot 15
  • Trine: Ultimate Collection Screenshot 16
  • Trine: Ultimate Collection Screenshot 17
  • Trine: Ultimate Collection Screenshot 18
  • Trine: Ultimate Collection Screenshot 19
  • Trine: Ultimate Collection Screenshot 20
  • Trine: Ultimate Collection Screenshot 21
  • Trine: Ultimate Collection Screenshot 22

Region restrictions

Activates within United States
This game has world-wide activation. No known region restrictions in effect.

Description

Requirements

Mac ReqsMinimumSupportedWill It Run?
Mac OS10.11Download the MacGameStore App to compare your Mac's information in real-time.

Get the Mac App
64bit SupportUnknown
CPU TypeIntel or Apple Silicon
CPU Cores2
CPU SpeedAny
System RAM4 GB
Drive Space12 GB
Video RAMAny
Important Notes:
  • Requires Steam and a Steam Account to download & play.

  • IMPORTANT: According to Steam, the mac versions of this game are NOT compatible with Catalina. Wether this is true or not, is currently unknown.
  • IMPORTANT: Trine 4 is currently not macOS compatible.
  • NOTE: Please be advised that Trine 1 & 2 do not run on Intel graphics solutions used in 2006-2008. The games will run on new (2010-) Intel HD Graphics 3000 or better. Macs with NVIDIA GeForce 9400M or ATi Radeon X1600 may not achieve smooth gameplay.
  • NOTE: Please be advised that Trine 3: The Artifacts of Power does not run on older MacBooks. Requires at least Intel HD Graphics 4000 or better. All Macs produced since Late 2013 are able to run the game.
Other Requirements:
Keyboard, Mouse/Trackpad with Secondary click enabled.

Reviews & Comments

5
From 1 Shopper
5
 
1
4
 
0
3
 
0
2
 
0
1
 
0
No reviews to list at this time.