Batman: Arkham City Game of the Year Edition

  • Batman: Arkham City Game of the Year Edition Screenshot 1
  • Batman: Arkham City Game of the Year Edition Screenshot 2
  • Batman: Arkham City Game of the Year Edition Screenshot 3
  • Batman: Arkham City Game of the Year Edition Screenshot 4
  • Batman: Arkham City Game of the Year Edition Screenshot 5
  • Batman: Arkham City Game of the Year Edition Screenshot 6
  • Batman: Arkham City Game of the Year Edition Screenshot 7
  • Batman: Arkham City Game of the Year Edition Screenshot 8
  • Batman: Arkham City Game of the Year Edition Screenshot 9

Region restrictions

Activates within United States
This game has world-wide activation. No known region restrictions in effect.

Description

Requirements

Mac Reqs Minimum Supported Will It Run?
Mac OS X10.14Download the MacGameStore App to compare your Mac's information in real-time.

Get the Mac App
64bit SupportYes
CPU TypeIntel Mac Only
CPU CoresAny
CPU Speed2 GHz
System RAM4 GB
Drive Space16 GB
Video RAM512 MB
Video (ati)AMD FirePro D300 *
* Unsupported Video Cards: ATI Radeon X1300, ATI Radeon X1600, ATI Radeon X1900 XT, ATI Radeon HD 2400 XT, ATI Radeon HD 2600 Pro, ATI Radeon HD 2600 XT, ATI Radeon HD 4670, ATI Radeon HD 4850, ATI Radeon HD 4870, ATI Radeon HD 5670, ATI Radeon HD 5750, ATI Radeon HD 5770, ATI Radeon HD 5870, AMD Radeon HD 6490M, AMD Radeon HD 6630M, AMD Radeon HD 6750M, AMD Radeon HD 6770M, AMD Radeon HD 6970M
Video (nvidia)NVIDIA GeForce GT 640M *
* Unsupported Video Cards: NVIDIA Quadro FX 4500, NVIDIA Quadro FX 5600, NVIDIA GeForce Go 7300, NVIDIA GeForce 7300 GT, NVIDIA GeForce 8600M GT, NVIDIA GeForce 8800 GS, NVIDIA GeForce 8800 GT, NVIDIA GeForce 9400M, NVIDIA GeForce 9400, NVIDIA GeForce 9600M GT, NVIDIA GeForce GT 120, NVIDIA GeForce GT 130, NVIDIA GeForce 320M, NVIDIA GeForce GT 330M, NVIDIA GeForce GT 540M
Video (intel)Intel HD Graphics 4000 *
* Unsupported Video Cards: Intel GMA 900, Intel GMA 950, Intel GMA X3100, Intel HD Graphics, Intel HD Graphics 3000
Important Notes:
  • Requires Steam and a Steam Account to play.
  • * All MacBooks released since Early 2016
  • * All MacBook Airs released since Mid 2012
  • * All MacBook Pros released since Mid 2012
  • * All Mac minis released since Late 2012
  • * All iMacs released since Late 2012
  • * All iMac Pro released since Late 2017
  • * All Mac Pros released since Late 2013 with a recommended Metal-capable graphics card
Other Requirements:
Players using a version of OS X before 10.14 can access a compatible version of the game via the Beta tab in the game’s properties window. Select the ‘mac_retail_11 - macOS 10.13.6 or older only' branch for a version that is compatible with 10.9.5 up to 10.13.6.

Reviews & Comments

0
From 0 Shoppers
5
 
0
4
 
0
3
 
0
2
 
0
1
 
0
No reviews to list at this time.

More By Feral Interactive